New program to help set up VASL scenarios

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
so when I down loaded the Chapter H notes I got a bunch of png files that won't open. Everything works fine except no pictures for the vehicles or ordnance. Any thoughts on how to fix this?
You have to cut and paste the sections from the DYO sections in the ASLRB over the respective blank png files. Another tip is to ensure the sections are 100% size,in the template settings, when you snip them. Secondly, unless you store the images online then you will be the only one that can see them when you set a scenario up.
It’s a huge undertaking, my advice is to snip and copy as and when you need the files and be aware of the limitations of who will be able to the see the details. Ideally you need a copy of the electronic Rulebook, or it really does become labour intensive.

cheers

Paul
 
Last edited:

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
I am now running VASL 6.6.3.1 using VASSAL 3.6.4. When I am creating vehicles/artillery for templates, the image appears perfectly. However, when I snip and put it onto the label in the VASL page, this is what appears.

20577
As you can see, the vehicle image has vanished. Is there any way to resolve this issue?
 

von Marwitz

Forum Guru
Joined
Nov 25, 2010
Messages
14,498
Reaction score
10,504
Location
Kraut Corner
Country
llUkraine
I am now running VASL 6.6.3.1 using VASSAL 3.6.4. When I am creating vehicles/artillery for templates, the image appears perfectly. However, when I snip and put it onto the label in the VASL page, this is what appears.

20578

As you can see, the vehicle image has vanished. Is there any way to resolve this issue?
Extremly Heavy Fog? ;)

Sorry, I just had to... Apologies, but no idea what the cause might be.

von Marwitz
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
As far as I am aware it hasn't been tested with 3.6.4, that may the problem? I haven't tried inserting any vehicle notes since VASSAL 3.5.8
I am now running VASL 6.6.3.1 using VASSAL 3.6.4. When I am creating vehicles/artillery for templates, the image appears perfectly. However, when I snip and put it onto the label in the VASL page, this is what appears.

View attachment 20577
As you can see, the vehicle image has vanished. Is there any way to resolve this issue?
Templates 1.8 only supports VASL up to 6.6.3. That could be the issue.
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
I am now running VASL 6.6.3.1 using VASSAL 3.6.4. When I am creating vehicles/artillery for templates, the image appears perfectly. However, when I snip and put it onto the label in the VASL page, this is what appears.

View attachment 20577
As you can see, the vehicle image has vanished. Is there any way to resolve this issue?
In settings link templates to the 6.3.3 VASL module in your VASL module folder. You can still do this even if you are running 6.3.3.1 to play ASL. There isn't a 6.3.3.1 in the template program, that's probably why you are seeing the blank pictures. I'm running 6.3.3.1 and VASSAL 3.6.4 and have just successfully loaded the counter details and icons into a scenario as HTML snippets.
 

Gordon

Forum Guru
Joined
Apr 6, 2017
Messages
2,521
Reaction score
3,003
Country
llUnited States
I'm trying out vasl-templates for the first time and am interested in playing around with the Chapter H features. However it isn't clear to me how the ".X" entries are handled. e.g., German vehicle 9.1 "FT-17 730(f) & FT-17 730(f)". I only see ".png" files for "whole number" entries.
 
Last edited:

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
In settings link templates to the 6.3.3 VASL module in your VASL module folder. You can still do this even if you are running 6.3.3.1 to play ASL. There isn't a 6.3.3.1 in the template program, that's probably why you are seeing the blank pictures. I'm running 6.3.3.1 and VASSAL 3.6.4 and have just successfully loaded the counter details and icons into a scenario as HTML snippets.
Do you mean 6.6.3? I have linked to that and it doesn't seem to resolve the issue.
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
Do you mean 6.6.3? I have linked to that and it doesn't seem to resolve the issue.
not sure what’s happening then, TBH. If you want the full text (the snipped section from the DYO data) to appear in addition to the counter info I think you need to export the full template to a saved game file. I haven’t tried that using my current configuration, but it did work using earlier versions of VASL/VASSAL.
 

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
not sure what’s happening then, TBH. If you want the full text (the snipped section from the DYO data) to appear in addition to the counter info I think you need to export the full template to a saved game file. I haven’t tried that using my current configuration, but it did work using earlier versions of VASL/VASSAL.

How would I do that? Do I just drag the main templates folder into the latest saved game folder?
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
ok, I'm assuming that when you load the templates program it is not throwing up any error massages regarding the location of your VASL module and or the location of VASSAL you are using. You will get a warning that things may not work if there is a VASSAL version mismatch, so far I haven't had any problems.

And that all the VASL/VASSAL/User templates settings are correct in the templates server settings and that you have installed the chromedriver.exe file and linked it via the Support programs in the server settings window.
I have my driver located here
C:/Program Files/Google/Chrome/Application/chromedriver.exe


if any of that data is missing or pointing to the wrong folder the program won't work.
Note: the 'java' window in the support programs can be left blank.

Note that the VASL module link is to your 6.6.3 vmod (wherever you store your VASSAL Modules) but the 'VASL extensions' link is to the 6.6.3 mod in templates data folder.

Assuming all that is in place you should be able to create a template and the counter icons along with info from the backs of the counters will be usable in the template. If the counter has the information from the DYO section of the aslrb stored in a png file then a small snippet icon will appear to the right of the counter when it is loaded in the template.
when complete you can save your template as a .json file. from the dropdown menu and you can update a saved game file with the information on the template that you have just created from the same dropdown menu.
That will load everything and overlay it on the VASL saved game file. you can then move the blocks of info around as you would for any other overlay.
Alternatively you can just upload the counter and vehicle info as separate HTML snippets and paste them into a label text box.

I will say that I took a full day to get my head around how to work the program and start loading the output into a saved game file. I still struggle with the photo upload part of it TBH. but as noted earlier, unless the data is online only you will see the DYO output in your scenario. Counters and scenario info will be visible to all though.

The user notes are useful, but there is an assumption of a base level of familiarity with some of the terminology and HTML language, which I don't have so there was a fair bit of trial and error before I 'got it'.

One final point, try setting the image scaling at 100% in the user data settings, otherwise your snipped images may appear too small, subject to the resolution of your monitor
 
Last edited:

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
ok, I'm assuming that when you load the templates program it is not throwing up any error massages regarding the location of your VASL module and or the location of VASSAL you are using. You will get a warning that things may not work if there is a VASSAL version mismatch, so far I haven't had any problems.

And that all the VASL/VASSAL/User templates settings are correct in the templates server settings and that you have installed the chromedriver.exe file and linked it via the Support programs in the server settings window.
I have my driver located here
C:/Program Files/Google/Chrome/Application/chromedriver.exe


if any of that data is missing or pointing to the wrong folder the program won't work.
Note: the 'java' window in the support programs can be left blank.

Note that the VASL module link is to your 6.6.3 vmod (wherever you store your VASSAL Modules) but the 'VASL extensions' link is to the 6.6.3 mod in templates data folder.

Assuming all that is in place you should be able to create a template and the counter icons along with info from the backs of the counters will be usable in the template. If the counter has the information from the DYO section of the aslrb stored in a png file then a small snippet icon will appear to the right of the counter when it is loaded in the template.
when complete you can save your template as a .json file. from the dropdown menu and you can update a saved game file with the information on the template that you have just created from the same dropdown menu.
That will load everything and overlay it on the VASL saved game file. you can then move the blocks of info around as you would for any other overlay.
Alternatively you can just upload the counter and vehicle info as separate HTML snippets and paste them into a label text box.
I will say that I took a full day to get my head around how the work the program and start loading the output into a saved game file. I still struggle with the photo upload part of it TBH. but as noted earlier, unless the data is online only you will see the DYO output in your scenario. Counters and scenario info will be visible to all though.
The user notes are useful, but there is an assumption of base level of familiarity with some of the terminology and HTML language, which I don't have so there was a fair bit of trial and error before I 'got it'.

One final point, try setting the image scaling at 100% in the user data settings, otherwise your snipped images may appear too small, subject to the resolution of your monitor
Does this look right?

20617

If not, what do I need to add? If so, what do I do next?
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
mostly,

The big error is that you are not linking to the 6.6.3 extension in the template program, it's in the data folder.

substitute the drive paths below with your own to your boards folder and to the other folders as appropriate for your PC.

VASSAL/VASL
VASL extension
s: should look something like this
C:/VASL Templates 1.9 beta (4)/data/vasl-6.6.3

I am using 1.9 Beta but it will work with whatever version you are using, wherever it is located on your PC

VASL Boards: F:/VASSAL/VASSAL Modules/VASL/boards

User data

Chapter H notes
: C:/VASL Templates 1.9 beta (4)/Chapter H Notes

User Files: C:/VASL Templates 1.9 beta (4)/examples/My Scenario templates
Ideally create a folder to store your own templates when they are created. Mine is a subfolder in the examples folder
 
Last edited:

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
mostly,

The big error is that you are not linking to the 6.6.3 extension in the template program, it's in the data folder.

substitute the drive paths below with your own to your boards folder and to the other folders as appropriate for your PC.

VASSAL/VASL
VASL extension
s: should look something like this
C:/VASL Templates 1.9 beta (4)/data/vasl-6.6.3

I am using 1.9 Beta but it will work with whatever version you are using, wherever it is located on your PC

VASL Boards: F:/VASSAL/VASSAL Modules/VASL/boards

User data

Chapter H notes
: C:/VASL Templates 1.9 beta (4)/Chapter H Notes

User Files: C:/VASL Templates 1.9 beta (4)/examples/My Scenario templates
Ideally create a folder to store your own templates when they are created. Mine is a subfolder in the examples folder
Sorry that I find this to very confusing. Do I need a boards folder now that they download automatically? I have created on but just move boards into it that are downloaded as I go along.

Does this look right now?

20620
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
Sorry that I find this to very confusing. Do I need a boards folder now that they download automatically? I have created on but just move boards into it that are downloaded as I go along.

Does this look right now?

View attachment 20620
that looks ok, you just need to fill in the user data boxes with the paths to Chapter H notes, user files ( the folder where you will store your created templates) in your templates program and set image scaling to 100%. You can always reduce it if scanned images are too large.

I've always had a boards folder, going all the way back to the first iteration of VASL. I had no idea you could run the program without it. I know that boards are automatically updated to the latest versions as and when you use them.

Yup, I found it confusing as well. took a good while to figure out where to store the chrome driver file. IIRC I had to delve into hidden folders. Once it's running and you've created your first template it's quite easy to use. If you do decide to scan chunks of data from the DYO section of the ASLRB, and copy the snips into the Chapter H folder you will need to restart the templates program before they appear in your template (another little learning curve).
 
Last edited:

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
that looks ok, you just need to fill in the user data boxes with the paths to Chapter H notes, user files ( the folder where you will store your created templates) in your templates program and set image scaling to 100%. You can always reduce it if scanned images are too large.

I've always had a boards folder, going all the way back to the first iteration of VASL. I had no idea you could run the program without it. I know that boards are automatically updated to the latest versions as and when you use them.
Image scaling now set to 100%. The full image of the counter appears im the templates page but the image of the vehicle disappears when it is snipped and transferred to VASL. I'm stumped!
Many thanks for taking the time and trouble to try to resolve the issue.
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
Silly question, but are you pasting the the snippet using control+V into the text box of the VASL label overlay? Other than that I am also stumped. I think you will have to wait for Pacman Ghost to respond and resolve the problem..
 

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
Silly question, but are you pasting the the snippet using control+V into the text box of the VASL label overlay? Other than that I am also stumped. I think you will have to wait for Pacman Ghost to respond and resolve the problem..
Of course. All the info appears in the label overlay but not the image of the vehicle/ordnance.

Before:

20624

After:

20625
 

Paul_RS

Elder Member
Joined
Feb 14, 2010
Messages
1,723
Reaction score
765
Location
Gammonopolis
Country
llUnited Kingdom
Of course. All the info appears in the label overlay but not the image of the vehicle/ordnance.

Before:

View attachment 20624

After:

View attachment 20625
ok, think I've got it. when you open the templates program. Go to the menu icon on the top right corner of the victory conditions window. from the drop down menu go to settings. Go to the 'Get images from box' and select internet. That should fix it..... I think?
 

Doug Leslie

Elder Member
Joined
Dec 6, 2017
Messages
1,686
Reaction score
1,654
Location
Scotland
Country
llUnited Kingdom
ok, think I've got it. when you open the templates program. Go to the menu icon on the top right corner of the victory conditions window. from the drop down menu go to settings. Go to the 'Get images from box' and select internet. That should fix it..... I think?
Eureka!

Thanks for saving me from a descent into madness.
 
Top