New program to help set up VASL scenarios

Pacman Ghost

Senior Member
Joined
Feb 25, 2017
Messages
569
Reaction score
287
Location
A maze of twisty little passages, all alike
Country
llAustralia
The first beta of the v1.9 release cycle is now available. If you're on Windows, you can get it here. If you're using Docker, or running from source, there's a new branch on Github.

The main new feature is the ability to set precise colors in the log file analysis graphs. For the guys who were asking for this, I think you'll like how it's been done... :)

Other minor features and bug fixes:
  • Changed how the webapp is served.
  • Tightened up how the Docker image is built.
  • The Java version is now shown in the Program Info dialog.
  • Accelerator underlines are now shown in the Server Settings dialog on Windows.
 

Neal

Senior Member
Joined
Jan 29, 2020
Messages
324
Reaction score
673
Location
PNW WA State
Country
llUnited States
Very nice. Nationality colors are built in as selections now (or enter a custom hex).
 

Gianluca G

Recruit
Joined
Jan 2, 2022
Messages
5
Reaction score
5
Location
Valais - Swiss
First name
Gianluca
Country
llSwitzerland
Nice stuff, but for me i have 2 error :
1-i don't see image form internet
2-error for VASL "Can't load the Vasl module: [Errno 2] No such file or directory

If someone have the same issue, plz can you tell me how i can fix it.

regards
Gianluca G
 

Pacman Ghost

Senior Member
Joined
Feb 25, 2017
Messages
569
Reaction score
287
Location
A maze of twisty little passages, all alike
Country
llAustralia
Dutch army logo in ww2 is not the polish one,
Sigh... Thanks for the heads-up. I think the reason I used the flag I did is because that's what's in the National Capabilities chart for the Allied Minors. But it's always bugged me they all had the same flag :)

I took a look at a few scenario cards, and MMP/AH seem to be using this:
20042
 

Doug Leslie

Senior Member
Joined
Dec 6, 2017
Messages
997
Reaction score
826
Location
Scotland
Country
llUnited Kingdom
I have just uploaded the most recent version of VASL Templates (1.8). When I try to add vehicles to the information pane, I get the following:

20158

How do I restore the images?
 

Chris NL

Member
Joined
Mar 10, 2008
Messages
296
Reaction score
52
Location
Netherlands
Country
llNetherlands
Sigh... Thanks for the heads-up. I think the reason I used the flag I did is because that's what's in the National Capabilities chart for the Allied Minors. But it's always bugged me they all had the same flag :)

I took a look at a few scenario cards, and MMP/AH seem to be using this:
View attachment 20042
That is the ASL logo, good for me too.
 

Pacman Ghost

Senior Member
Joined
Feb 25, 2017
Messages
569
Reaction score
287
Location
A maze of twisty little passages, all alike
Country
llAustralia
That is the ASL logo, good for me too.
Whatever it is, it's butt-ugly :rolleyes: But, the problem with the flag you posted is that, when it gets reduced down to 16x16, it's going to be an unrecognizable splodge.

If it bugs you, there's a post elsewhere in this thread that explains how you can configure custom flags (you have to edit the nationalities.json file and add a URL that points to a new image).
 

Doug Leslie

Senior Member
Joined
Dec 6, 2017
Messages
997
Reaction score
826
Location
Scotland
Country
llUnited Kingdom
File, Settings menu in the vasl-templates program.
What do I do next? Do I have to create a link to every option? I have linked to the Vassal module that I am using but when I link to VASL 6.6.4 beta 2 in my downloads, I get this message-

Can't load the VASL module (Errno 2) C\\Users\dougb\\Dropbox\\MyPC\\Downloads\\Vassaltemplates-v1.7.windows(2)\\data\\VASL-beta2\\VASL-overrides.json"

This might as well be in Swahili for all the sense that I can make of it but I recently cleared what I thought were redundant folders from my Dropbox in order to create more space. Is there something that I need to re-install?
 

Doug Leslie

Senior Member
Joined
Dec 6, 2017
Messages
997
Reaction score
826
Location
Scotland
Country
llUnited Kingdom
I'm still toiling here. I can produce AFV images in Templates by drawing from 6.6.1 but, when I snip and transfer them, the images disappear. I am using Vassal 3.5.8.
 

j42k

Recruit
Joined
Jan 6, 2021
Messages
4
Reaction score
0
Country
llUnited States
I think you've configured the wrong thing for the VASL module. It should be the .vmod file.
EDIT: I got this working. For some reason, vasl-6.6.2.vmod does not work. When I used vasl-6.6.3.vmod (or even vasl-6.6.1.vmod) they both worked. So I'm now using VASL-6.6.3.vmod. Bottom line, on a Macintosh, I have 100% usability of the VASL-templates running vasl-templates v1.8

**
Original:
I am having the same problem. vasl-templates will run (localhost:5010). However, I get the same error: "Can't load the VASL module: "There is no item named 'buildFile' in the archive"". I am using a valid VASL module (VASL-6.6.2.vmod) and there is a build file within it.

I'm using VASL_tempates v1.8 on a MacBook Pro running macOS Monterey (12.2). Python 3.10.2
 
Last edited:

Desicat

Member
Joined
Apr 24, 2016
Messages
78
Reaction score
44
Location
MN
Country
llUnited States
so when I down loaded the Chapter H notes I got a bunch of png files that won't open. Everything works fine except no pictures for the vehicles or ordnance. Any thoughts on how to fix this?
 

Attachments

Top