VASL6.6.7-beta2.vmod released

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
There are other situations that produce the problem, but in my experience, the above ALWAYS produces the problem.
I can replicate the problem with the chatter. The cause is obscured by, if not due to, to the way the ASLChatter recreates rather than reuses parts of Chatter.

I'm digging into this now...
 
Last edited:

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
@ScottRomanowski @PresterJohn
I have tried the VASSAL build provided by @uckelman.

Using that build with VASL6.6.6 and my latest 6.6.7beta,

  1. I cannot trigger the text message hesitation problem anymore.
  2. I cannot trigger characters being drawn in chat window when using the mouse wheel
  3. The Marked Moved preference under General is back. (It had disappeared in VASSAL3.6.X)
I would appreciate it if you could test for the first two issues on your devices.

@uckelman seems like a success to me.

Do you have a time line for the likely release of VASSAL3.7.0?
 

PresterJohn

Senior Member
Joined
Feb 13, 2022
Messages
986
Reaction score
556
Location
The Orient
Country
llAustralia
@ScottRomanowski @PresterJohn
I have tried the VASSAL build provided by @uckelman.

Using that build with VASL6.6.6 and my latest 6.6.7beta,

  1. I cannot trigger the text message hesitation problem anymore.
  2. I cannot trigger characters being drawn in chat window when using the mouse wheel
  3. The Marked Moved preference under General is back. (It had disappeared in VASSAL3.6.X)
I would appreciate it if you could test for the first two issues on your devices.

@uckelman seems like a success to me.

Do you have a time line for the likely release of VASSAL3.7.0?
Yep, it's good for me - no mystery symbols from my Logitech scroll wheels are showing up in the chat window.
 

ScottRomanowski

Forum Guru
Joined
Jul 31, 2010
Messages
1,651
Reaction score
2,132
Location
Massachusetts
Country
llUnited States
Using that build with VASL6.6.6 and my latest 6.6.7beta,
1. I cannot trigger the text message hesitation problem anymore.
I'll test that tonight or tomorrow. I'm sorry I can't do it faster.

ETA: I cannot get the problem to appear either. I think it's fixed. :)
 
Last edited:

Jeff Leslie

Member
Joined
Jan 29, 2003
Messages
347
Reaction score
49
Location
Akron, Ohio
Country
llUnited States
Now I get a new error with VASSAL 3.7.0 and VASL 6.6.7beta5...

Moved pieces do not get the "Moved" flag when I move them, even though I have the box checked "Show when pieces have been marked as moved". Even when I edit the main map display to say "Always" mark pieces as moved (as opposed to "use preferences setting").
 

lionelc62

Senior Member
Joined
Nov 16, 2007
Messages
410
Reaction score
452
Location
Northern France
First name
Lionel
Country
llFrance
Now I get a new error with VASSAL 3.7.0 and VASL 6.6.7beta5...

Moved pieces do not get the "Moved" flag when I move them, even though I have the box checked "Show when pieces have been marked as moved". Even when I edit the main map display to say "Always" mark pieces as moved (as opposed to "use preferences setting").
I have the same problem/ No 'moved' flag on the counters. I had the same problem with VASL 6.6.6 and VASSAL 3.7.0
 

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
Both VASSAL and VASL need to be changed in order to restore the Mark Moved functionality. VASSAL 3.7.0 contains the required changes. The required VASL changes are not in VASL667beta5.

I have a beta7 version in which the counter flag is working but reporting to the chat window is not.
 

lionelc62

Senior Member
Joined
Nov 16, 2007
Messages
410
Reaction score
452
Location
Northern France
First name
Lionel
Country
llFrance
Both VASSAL and VASL need to be changed in order to restore the Mark Moved functionality. VASSAL 3.7.0 contains the required changes. The required VASL changes are not in VASL667beta5.

I have a beta7 version in which the counter flag is working but reporting to the chat window is not.
I have VASSAL 3.7.0 and VASL 667beta 5 and the moved flag doesn't appear when I move my squads.
Lionel
 

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
the counter flag is working but reporting to the chat window is not.
The reason reporting to the chat window was not working is that I had deselected the "Auto-report moves" preference under General. Yesterday was a shit-for-brains day! All better now. LOL.
 
Top