VASL 6.4.2-beta1 now available

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
466
Reaction score
545
Location
Ottawa
Country
llCanada
Click here to download the VASL 6.4.2-beta1 module.

This is a test module not an official release.

It has one and only one purpose and that is to enable LOS Checking on certain boards with a particular configuration, namely the BFP DW boards. If you want to use those boards and the los checking functionality, download this module. If you don't, there is nothing for you to see here, move on.

LOS Checking has now been enabled on the BFP boards from Pif, and ITR2. Updated board versions, and in some cases, newly released boards will show up on the VASL.info website shortly. For those who use auto-synching, the updated board versions will download when you select one of these boards as part of a scenario.

Updated boards: BFPDW5a, BFPDW5b, BFPDW6a, BFPDW6b, BFPO, BFPP, BFPQ, BFPR.
New boards: BFPDW7a, BFPDW7b.
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
I take it that the new boards have not been released yet, but I have this new Beta, and am ready to start kicking the tires when I have something to kick!
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
466
Reaction score
545
Location
Ottawa
Country
llCanada
The updated boards with los checking enabled are released and are on the website and should download if you use auto-synching. The website does not show anything to indicate a new version exists. Note that the new versions are NOT in the BFP DW1-DW6 bundle, you have to download them individually.

I am having a glitch getting BFPDW7a and BFPDW7b to show on the website. Hope to have that remedied soon.
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
A question, Doug --

Since this is just a board/LOS update, would this also work in 6.4.1? (having a little trouble with my Vassal recognizing 6.4.2).
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
466
Reaction score
545
Location
Ottawa
Country
llCanada
A question, Doug --

Since this is just a board/LOS update, would this also work in 6.4.1? (having a little trouble with my Vassal recognizing 6.4.2).
The only thing that won't work is LOS Checking BFP DW "b" boards as the code fix addresses this board configuration in particular. For all the other updated boards, 6.4.1 will work fine. And the basic los string (which just shows the range and not whether the los is clear or blocked) should still work on the "b" boards.

Not sure what's up with your VASSAL. What kind of error messages are you getting? What version of VASSAL do you have?
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
Thx 4 the prompt reply and the specific information about the board fixes --
My problem with the VASSAL/VASL is not in downloading or getting a new VASL version to show up, but one of keeping it around when I get the new version to stick around after I sign off. So far, it has just been a matter of reloading the new VASL, after which it works fine and lasts a long time. It's on my 'puter right now. It is bothersome how it will disappear after that first download and install.

This is not peculiar to 6.4.2b. It has plagued my VASL installs for some time now.

OBTW, I have VASSAL 3.2.17, VASL 6.4.1, plus your betas.

P.S. the DWxb boards work fine now. Thx
Larry
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
466
Reaction score
545
Location
Ottawa
Country
llCanada
Thx 4 the prompt reply and the specific information about the board fixes --
My problem with the VASSAL/VASL is not in downloading or getting a new VASL version to show up, but one of keeping it around when I get the new version to stick around after I sign off. So far, it has just been a matter of reloading the new VASL, after which it works fine and lasts a long time. It's on my 'puter right now. It is bothersome how it will disappear after that first download and install.

This is not peculiar to 6.4.2b. It has plagued my VASL installs for some time now.

OBTW, I have VASSAL 3.2.17, VASL 6.4.1, plus your betas.

P.S. the DWxb boards work fine now. Thx
Larry
How do you add a VASL module to VASSAL?
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
OK, here's what I do (some of you grognards be ready to snicker!) --
First of all, I download the new version of VASSAL - the instructions are right up at the head of this topic. Sure, he tends to meander a lot in his instruction, but it works.

After downloading VASSAL into drive C: , I then copy it into my USB drives E: and F: -- can't have too many copies!

I now have a tree that looks like this:
C: -- VASSAL Mods -- ASL -- boards --
I also have places to put extensions, overlays, and scenarios.
 

Robin Reeve

Aka the Swiss Moron
Gold Supporting Member
Joined
Jul 26, 2003
Messages
17,101
Reaction score
2,523
Location
St-Légier
First name
Robin
Country
llSwitzerland
How do you add a VASL module to VASSAL?
You download the module in a folder.
You launch Vassal.
You choose "Play a new Module".
You navigate from that menu to your module.
You double-click on it (or click on "OK").
Your module will now run and Vassal will put it in the list if modules that appears upom opening.
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
Correct, Swiftandsure!
The only difference in our procedure is that first I must specify which "Drive" I am launching VASSAL from -- C:, E: or F:, the last two of which are USB memory sticks.
None of which explains the shy and coy behavior of these VASL upgrades, but it is not a show-stopper, but a mere ball-buster, so as long as I can will them into submission thru repeated and merciless beating.
 

zgrose

Elder Member
Joined
Jun 13, 2004
Messages
3,751
Reaction score
617
Location
Kingwood, TX
First name
Zoltan
Country
llUnited States
OK, here's what I do (some of you grognards be ready to snicker!) --
First of all, I download the new version of VASSAL - the instructions are right up at the head of this topic. Sure, he tends to meander a lot in his instruction, but it works.
No, how do you install VASL (one S) into your VASSAL (two S). If VASL keeps disappearing from your list, perhaps loading from different drives is somehow killing your preferences file? (edit2) Furthermore, what exactly happens if, after you've loading it once, and it disappears, if you just load it again?
 
Last edited:

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
If I just load it up again, it usually sticks around. I remember one time I had to do it twice.
Procedure:
1. Download the new VASL module from Doug's page.
2. Copy the downloaded VASL module, and paste it to the VASSAL associated with that drive.

I'm probably overlooking something here, but I haven't figured it out, mostly because when the thing settles down I quit looking for an answer.
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
466
Reaction score
545
Location
Ottawa
Country
llCanada
If I just load it up again, it usually sticks around. I remember one time I had to do it twice.
Procedure:
1. Download the new VASL module from Doug's page.
2. Copy the downloaded VASL module, and paste it to the VASSAL associated with that drive.

I'm probably overlooking something here, but I haven't figured it out, mostly because when the thing settles down I quit looking for an answer.
If you are "pasting into VASSAL" that suggests to me that it is actually disappearing from the drive and not just from the VASSAL list of modules. Is this the case?
 

zgrose

Elder Member
Joined
Jun 13, 2004
Messages
3,751
Reaction score
617
Location
Kingwood, TX
First name
Zoltan
Country
llUnited States
Not 100% sure where it goes in Windows, but my VASSAL prefs folder has a file called V_Global which seems to have a list of the modules to load. At the bottom it has something like:

modulesDir=/Users/zgrose/Dropbox/VASSAL/VASL
RecentModules=/Users/zgrose/Dropbox/VASSAL/Stalin/Stalins_War_v19.vmod,/Users/zgrose/Dropbox/VASSAL/VASL/vasl-6.3.3.vmod
showServerStatus=false

Can see if that's getting scrubbed.
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
zgrose, I don't know what you mean by V_Global. I'm using Windows 10 on a PC desktop. Think of me as an unfrozen caveman VASL kind of guy.
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
If you are "pasting into VASSAL" that suggests to me that it is actually disappearing from the drive and not just from the VASSAL list of modules. Is this the case?
No. It disappears from the VASSAL window, but is still in the "downloads" section. Backing out and re-entering from the "downloads" section brings it back up, usually, and then it sticks around. It's a mere annoyance mostly.
 

zgrose

Elder Member
Joined
Jun 13, 2004
Messages
3,751
Reaction score
617
Location
Kingwood, TX
First name
Zoltan
Country
llUnited States
zgrose, I don't know what you mean by V_Global. I'm using Windows 10 on a PC desktop. Think of me as an unfrozen caveman VASL kind of guy.
It’s in the prefs folder which might be hidden by default. There should be a Windows option to search for hidden files so some nice fellow might give you a full path.
 

Maxwelk1

Member
Joined
Apr 21, 2017
Messages
159
Reaction score
25
Location
Montross VA
First name
Lafajita
Country
llUnited States
Houston, we have a new problem.
Draggable Overlay RC-1 has a problem with sizing, i.e., when I attempt to enlarge it, per the button, I get some other overlay -- I think one from BtB.

Hopefully some of you nice people could have a look at this.
 

BigAl737

Elder Member
Joined
Apr 5, 2011
Messages
1,208
Reaction score
878
Location
AK
Country
llUnited States
Houston, we have a new problem.
Draggable Overlay RC-1 has a problem with sizing, i.e., when I attempt to enlarge it, per the button, I get some other overlay -- I think one from BtB.

Hopefully some of you nice people could have a look at this.
I’ll take a look Sunday night. Thanks for letting me know.
 
Top