Another VASL Bug

dwardzala

Va Tech Hokie
Joined
Apr 20, 2004
Messages
598
Reaction score
70
Location
Detroit/Ann Arbor Ar
Country
llUnited States
Not really game breaking but certainly annoying. The Start Up Wizard continues to show even after unchecking the box and completing the dialog (loading a saved game.) VASL 6.6.1
 

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
Is there a reason why you would want to uncheck the box? I have never known anyone else who has tried that but who knows what people do in the privacy of their own computers. . . . .

Seriously, is this a bug worth fixing? Does it let you do something faster or better? If so, I am willing to have a look but otherwise, I am inclined to say, check the box, move on, nothing to see here folks.
 

dwardzala

Va Tech Hokie
Joined
Apr 20, 2004
Messages
598
Reaction score
70
Location
Detroit/Ann Arbor Ar
Country
llUnited States
Its extra clicks to load a game. If it doesn't do anything then delete it. But if its there it should work. It also doesn't remember the directory for save games (I get null) so its not even useful for that.
 
Last edited:

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
True, but it's been there since the beginning of time and I have no idea what is causing the problem. To paraphrase, if the problem is easy to avoid, don't fix it. I will list it as a bug in any event.
 

dwardzala

Va Tech Hokie
Joined
Apr 20, 2004
Messages
598
Reaction score
70
Location
Detroit/Ann Arbor Ar
Country
llUnited States
It used to work at some point. I actually prefer to load the game from the control window. Not sure which version broke it. It might have been 6.6.
 

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
What version of VASSAL are you using? I suspect this may have more to do with VASSAL changes impacting VASL than anything else?
 

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
2,011
Reaction score
2,348
Location
Ottawa
Country
llCanada
Well, VASL 6.6.1 was built using 3.4.6 but I doubt that is a material difference.
 

Michael R

Minor Hero
Staff member
Moderator
Joined
Feb 4, 2003
Messages
4,695
Reaction score
4,263
Location
La Belle Province
First name
Michael
Country
llCanada
I do not see the VASSAL wizard. I haven't had it checked to run since 2015.

15357
 

dwardzala

Va Tech Hokie
Joined
Apr 20, 2004
Messages
598
Reaction score
70
Location
Detroit/Ann Arbor Ar
Country
llUnited States
So apparently the Show Wizard Check Box that shows up in the Wizard isn’t writing to the preference file if it is unchecked. I will go ahead and just change my preferences.
 

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
The problem you're seeing is due to a preferences writing bug we discovered a few days ago and fixed yesterday. This will work correctly in VASSAL 3.5.
 
Top