VASSAL None responsive

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Hi

anyone experienced the main VASSAL engine not firing up. I click on both the VASSAL and VASL icons on my screen and only get the whirling circle for a second or two then that goes away and no loading no error just nothing. Tried deleting and loading afresh but still no change, really stuck with no error messages

Ian
 

DougRim

Forum Guru
Joined
Apr 23, 2012
Messages
1,997
Reaction score
2,312
Location
Ottawa
Country
llCanada
I find them loading slower recently but loading all the same.
 

Larry

Elder Member
Joined
Oct 29, 2003
Messages
5,418
Reaction score
1,781
Location
Guada La Habra
Country
llUnited States
Sometimes the mouse settings for a double click could pose a problem in getting something to load. It isn't VASSAL or VASL but windows settings.
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Have you checked the error log for a run where this happens?
Hi, I don't get an error message or access to anything such as a log. It just does not load the VASSL engine, can't get as far as adding the VASL module. I have updated and replaced the old versions before with no issues. Looking like I will have to take it to a computer repair to get sorted

Ian
 

Jazz

Inactive
Joined
Feb 3, 2003
Messages
12,224
Reaction score
2,783
Location
The Empty Quarter
Country
llLithuania
Happens to me every now & again.....nothing a computer power cycle didn't fix?
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Happens to me every now & again.....nothing a computer power cycle didn't fix?
Computer power cycle? I am not good with sexy techo speak

OK looked it up and no switching off and on did not help any of the times I tried
 

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
Hi, I don't get an error message or access to anything such as a log. It just does not load the VASSL engine, can't get as far as adding the VASL module. I have updated and replaced the old versions before with no issues. Looking like I will have to take it to a computer repair to get sorted

Ian
Did you follow the link and read what was there? That's telling you where to find the error log file. There may well be one even if no windows opened at all. Please try that and confirm either way what you find.
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Did you follow the link and read what was there? That's telling you where to find the error log file. There may well be one even if no windows opened at all. Please try that and confirm either way what you find.
Oh OK my bad, tried to run again just now, then checked the error log. Only one showing was from me opening up a very old version of VASL (forgot how bad it used to look)
So looks like it's not loading far enough to get an error log. Please note had to cut most of the error log off as was too big to post

Thanks for the help


-- OS Windows 10
-- Java version 1.8.0_311
-- VASSAL version 3.0.18
No Translation: ResourceExtracter.select
-- VASL version 5.8.1
java.io.IOException: Couldn't locate data in ovrBE: boards\overlays\ovrBE (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.Overlay.setFile(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.parseOverlay(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
java.io.IOException: Couldn't locate data in ovrOC: boards\overlays\ovrOC (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.Overlay.setFile(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.parseOverlay(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
java.io.IOException: Couldn't locate data in ovrOC: boards\overlays\ovrOC (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.Overlay.setFile(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.parseOverlay(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
java.io.IOException: Couldn't locate data in ovrBE: boards\overlays\ovrBE (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.ASLBoard.fixImage(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
 

von Marwitz

Forum Guru
Joined
Nov 25, 2010
Messages
14,451
Reaction score
10,390
Location
Kraut Corner
Country
llUkraine
Oh OK my bad, tried to run again just now, then checked the error log. Only one showing was from me opening up a very old version of VASL (forgot how bad it used to look)
So looks like it's not loading far enough to get an error log. Please note had to cut most of the error log off as was too big to post

Thanks for the help


-- OS Windows 10
-- Java version 1.8.0_311
-- VASSAL version 3.0.18
No Translation: ResourceExtracter.select
-- VASL version 5.8.1
java.io.IOException: Couldn't locate data in ovrBE: boards\overlays\ovrBE (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.Overlay.setFile(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.parseOverlay(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
java.io.IOException: Couldn't locate data in ovrOC: boards\overlays\ovrOC (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.Overlay.setFile(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.parseOverlay(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
java.io.IOException: Couldn't locate data in ovrOC: boards\overlays\ovrOC (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.Overlay.setFile(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.parseOverlay(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)
java.io.IOException: Couldn't locate data in ovrBE: boards\overlays\ovrBE (The system cannot find the file specified)
at VASSAL.tools.DataArchive.getFileStream(DataArchive.java:122)
at VASL.build.module.map.boardPicker.Overlay.readData(Unknown Source)
at VASL.build.module.map.boardPicker.ASLBoard.fixImage(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.buildBoard(Unknown Source)
at VASL.build.module.map.ASLBoardPicker.decode(Unknown Source)
at VASSAL.launch.BasicModule.decodeSubCommand(BasicModule.java:180)
at VASSAL.launch.BasicModule.decode(BasicModule.java:164)
at VASSAL.launch.BasicModule.decode(BasicModule.java:170)
at VASSAL.build.module.GameState.decodeSavedGame(GameState.java:559)
at VASSAL.build.module.WizardSupport$SavedGameLoader.loadSavedGame(WizardSupport.java:543)
at VASSAL.build.module.WizardSupport$SavedGameLoader.run(WizardSupport.java:530)
at VASSAL.build.module.WizardSupport$LoadSavedGamePanels$1$1.run(WizardSupport.java:603)


-- Java version 1.8.0_311
-- VASSAL version 3.0.18
No Translation: ResourceExtracter.select
-- VASL version 5.8.


It seems that you have rather 'ancient' versions of both VASL and VASSAL.

My advice would be to install the most current versions of both (or at least the VASSAL version with which the current VASL version has been tested). A parallel installation of different Versions of VASSAL/VASL is possible. You might need to adjust the paths pointing to your Extensions and Map folders.

von Marwitz
 

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
Would you confirm what versions of Vassal and VASL you're trying to run?
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Would you confirm what versions of Vassal and VASL you're trying to run?
VASSAL 3.5.8 and VASLv663, the error log showed the failed loading of the very old one I have from decades ago that I got to work from a portable drive I still have it on
 

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
Ok. The next step is to check that the bundled Java in your Vassal install works. Where have you installed Vassal 3.5.8?
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Ok. The next step is to check that the bundled Java in your Vassal install works. Where have you installed Vassal 3.5.8?
It's on my main drive with shortcut to my desktop, both shortcut and C drive icons fail to load it
 

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
Please post the exact installation path. We need that in order to continue. (It sounds like it will start with something like C:\Program Files\VASSAL...)
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Please post the exact installation path. We need that in order to continue. (It sounds like it will start with something like C:\Program Files\VASSAL...)

c:\program files \vassal-3.5.8

that is the direct path

c:\program files (x86)\java

path to Java

Thanks
 

uckelman

Senior Member
Joined
Sep 12, 2011
Messages
722
Reaction score
452
Location
Durham
Country
llUnited Kingdom
Ok. The path to Java is irrelevant, because the Java you have installed isn't used if you've used Vassal's Windows installer.

Bring up a command prompt window. (On Win 10, you can type "cmd" in the search box and something will pop up that you can click on).

Then enter the following commands:

Code:
cd "C:\Program Files\VASSAL-3.5.8\jre\bin"
java.exe --version
What output do you see?
 

custardpie

Elder Member
Joined
Oct 18, 2008
Messages
6,375
Reaction score
620
Location
Nottingham
Country
llUnited Kingdom
Ok. The path to Java is irrelevant, because the Java you have installed isn't used if you've used Vassal's Windows installer.

Bring up a command prompt window. (On Win 10, you can type "cmd" in the search box and something will pop up that you can click on).

Then enter the following commands:

Code:
cd "C:\Program Files\VASSAL-3.5.8\jre\bin"
java.exe --version
What output do you see?
C:\program filea\VASSAL-3.5.8\jre\bin>java.exe --version
openjdk 16 2021-03-16
OpenJDK Runtime Environment AdoptOpenJDK (build 16+36)
OpenJDK 64-Bit Server VM AdoptOpenJDK (build 16+36, mixed mode)

C:\Program Files\VASSEL-3.5.8\jre\bin>
 
Top