VASL 6.6.1 PBEM and Scenarios

thosmos

Recruit
Joined
Jan 30, 2005
Messages
24
Reaction score
8
Location
Santa Fe, NM
First name
Thomas
Country
llUnited States
Playing some SK#2 scenarios. I used one from here (SK#9)

http://vasl.info/scenarios.htm

And we had issues with counters not moving on the map, though the log file was correct with recounting movement on the board.

Then we we noticed the link for boards that were more recently created. (I think even these were done 6 years ago)

https://github.com/atuline/ASLSK-Scenarios#asl-starter-kit-scenario-setups

We are trying to use them now, but have yet to get started. Again, trying SK9. (From SK#2)

But even these say that they were created using VASL 6.1.1.

I am wondering. I am trying to use previously created set ups, which seem pretty cool. But do most players just create their own set ups?

My opponent was using an older version of VASL. So, he updated to the 6.6.1 that I am using, and we still had issues. I thought it was because we had started the game with him running a different version of VASL, then updating it, and trying to continue.
 

A_T_Great

Senior Member
Joined
Oct 15, 2011
Messages
559
Reaction score
344
Location
Maine
Country
llUnited States
Playing some SK#2 scenarios. I used one from here (SK#9)

http://vasl.info/scenarios.htm

And we had issues with counters not moving on the map, though the log file was correct with recounting movement on the board.

Then we we noticed the link for boards that were more recently created. (I think even these were done 6 years ago)

https://github.com/atuline/ASLSK-Scenarios#asl-starter-kit-scenario-setups

We are trying to use them now, but have yet to get started. Again, trying SK9. (From SK#2)

But even these say that they were created using VASL 6.1.1.

I am wondering. I am trying to use previously created set ups, which seem pretty cool. But do most players just create their own set ups?

My opponent was using an older version of VASL. So, he updated to the 6.6.1 that I am using, and we still had issues. I thought it was because we had started the game with him running a different version of VASL, then updating it, and trying to continue.
It is always best to create your own setup using the current pieces and boards. Was it all the counters that wouldn't move?
 

thosmos

Recruit
Joined
Jan 30, 2005
Messages
24
Reaction score
8
Location
Santa Fe, NM
First name
Thomas
Country
llUnited States
The counters moved. Just all but one stack, didn’t represent what the log file said. We are trying the updated scenario creations now with the same scenario and so far it is working.
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
846
Reaction score
988
Location
Ottawa
Country
llCanada
See the release notes for vasl6.6.1 for info on version compatability.
 

A_T_Great

Senior Member
Joined
Oct 15, 2011
Messages
559
Reaction score
344
Location
Maine
Country
llUnited States
The counters moved. Just all but one stack, didn’t represent what the log file said. We are trying the updated scenario creations now with the same scenario and so far it is working.
The reason I asked, is sometimes when a counter in manipulated or covered with another counter by the opposing player during a logfile, the stack will no longer move from that point, but the log will continue to show the move that was made originally, just like you described.
 

thosmos

Recruit
Joined
Jan 30, 2005
Messages
24
Reaction score
8
Location
Santa Fe, NM
First name
Thomas
Country
llUnited States
I think my patient opponent figured out what could be the problem. He suggested that in settings I had “Auto-Report Moves?” unchecked. I will take a look. Hopefully, it’s something this simple.
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
846
Reaction score
988
Location
Ottawa
Country
llCanada
If you are using a setup file created with a vasl version before 6.5.0 and are playing it with a vasl version after 6.4.4 then you are going to have problems. Lots of problems. And no way to fix them beyond swapping out all of the unit counters.
 

thosmos

Recruit
Joined
Jan 30, 2005
Messages
24
Reaction score
8
Location
Santa Fe, NM
First name
Thomas
Country
llUnited States
If you are using a setup file created with a vasl version before 6.5.0 and are playing it with a vasl version after 6.4.4 then you are going to have problems. Lots of problems. And no way to fix them beyond swapping out all of the unit counters.
Thanks for the tip. I think we are doing just that. But in this case it seems that my “Auto-Report Moves?” Box was unchecked in preferences. Everything seems to be working — with this last turns movement, that is. But will watch out for other problems.

Looks like the set ups that we are using are using the following:

  • VASSAL Engine 3.2.15
  • VASL 6.2.2
  • V6 boards
We are both using VASL 6.6.1. (Uh oh...)
 

von Marwitz

Forum Guru
Joined
Nov 25, 2010
Messages
12,980
Reaction score
7,694
Location
Kraut Corner
Country
llGibraltar
Thanks for the tip. I think we are doing just that. But in this case it seems that my “Auto-Report Moves?” Box was unchecked in preferences. Everything seems to be working — with this last turns movement, that is. But will watch out for other problems.

Looks like the set ups that we are using are using the following:

  • VASSAL Engine 3.2.15
  • VASL 6.2.2
  • V6 boards
We are both using VASL 6.6.1. (Uh oh...)
See this post and a few following. Over there I have explained how you can quickly update such old VASL files to the current v6.6.1. In my examples, I have used a v6.3.3 file and an ancient v5.9.3 one, so you should be fine trying this with your v6.2.2 file.

von Marwitz
 
Top