Strange VASL 6.4.0 error

bprobst

Elder Member
Joined
Oct 31, 2003
Messages
2,341
Reaction score
1,114
Location
Melbourne, Australia
First name
Bruce
Country
llAustralia
Discovered what seems to be a very weird bug in 6.4.0. If one player uses either the "up" or "down" arrows to change the position of units in a stack (moving a counter to the top or the bottom of the stack respectively), the other player sees a spurious LOS thread appear on their screen (it appears to be a phantom fragment from some previous LOS check). Also, the "LOS" button on the QC bar contracts to an "L". If the affected player clicks on the "L" the view returns to normal.

The spurious LOS doesn't appear to have any effect other than the visual one -- you can still move units, roll dice, etc. Also, normal LOS checks work as expected.

Using the "Left" or "Right" arrows appears to cause no problems.
 

hongkongwargamer

Forum Guru
Joined
Apr 4, 2013
Messages
6,369
Reaction score
3,764
Location
.. beneath the Pale Moonlight
Country
llZimbabwe
Oh .. I saw that this morning as well in my Gavutu-Tanambogo game this morning .. one end of that LOS line kept following my cursor around, which is still okay except that the text label that details why you can or cannot see came with it as well, effectively blocking what I was trying to move.

I switched back down to 6.3.3.
 

GeorgeBates

Elder Member
Joined
Jan 22, 2009
Messages
1,936
Reaction score
736
Location
Live at Budokan
Country
llJapan
Until you realize what's going on, this is a "WTF?!?!" kind of glitch. One of the first instances it appeared I was checking LOS at the same time and it locked my session, although not my opponent's, thank goodness.
 

Robin Reeve

φιλέω ASL אני אוהב
Staff member
Moderator
Gold Supporting Member
Joined
Jul 26, 2003
Messages
17,370
Reaction score
2,740
Location
St-Légier
First name
Robin
Country
llSwitzerland
All l know, is that when you string an LOS to hex with different levels in it, using the up and down arrow shows the different possible LOS, depending on the Level targeted.
Perhaps did the programation of that feature mix up the other use of the up/down arrows?
 

Michael R

Minor Hero
Staff member
Moderator
Silver Supporting Member
Joined
Feb 4, 2003
Messages
3,294
Reaction score
1,791
Location
La Belle Province
First name
Michael
Country
llCanada
Oh man, I'm glad someone figured out the trigger. I saw it happen, but I had no idea what triggered it.
 

Sully

Senior Member
Joined
Feb 2, 2003
Messages
1,153
Reaction score
244
Location
Mpls, MN
Country
llUnited States
I've bugged it. There was a gap in the LOS logic where using the up/down arrows to change the level was only showing on the local machine. It seems that fix is not checking if the LOS is currently active.

If it is driving you nuts don't forget you can disable LOS checking in the preferences.
 

DougRim

Senior Member
Joined
Apr 23, 2012
Messages
583
Reaction score
666
Location
Ottawa
Country
llCanada
I am trying to fix this bug. So far, I have been unable to replicate it. Any chance you could give me a bit more detail about when it happened, such as what versions of VASL you were using, and which players did the LOS Check and the subsequent use of the Up/Down Arrow keys? Thanks!
 

bprobst

Elder Member
Joined
Oct 31, 2003
Messages
2,341
Reaction score
1,114
Location
Melbourne, Australia
First name
Bruce
Country
llAustralia
I will note in passing, not necessarily related to the specific bug described in this thread, but the 6.4.0 LOS engine crashes a lot. When it's working it seems to work fine; it's the keeping it working that seems difficult.

If the engine causes so much grief, perhaps it would be better to disable it altogether. I'm happy with a plain 'ol LOS string. I can count blind hexes and hindrances for myself.
 

Sully

Senior Member
Joined
Feb 2, 2003
Messages
1,153
Reaction score
244
Location
Mpls, MN
Country
llUnited States
When you say crashing are you getting the VASSAL error dialog or something else?

You can disable the LOS engine in the preferences BTW.

I will note in passing, not necessarily related to the specific bug described in this thread, but the 6.4.0 LOS engine crashes a lot. When it's working it seems to work fine; it's the keeping it working that seems difficult.

If the engine causes so much grief, perhaps it would be better to disable it altogether. I'm happy with a plain 'ol LOS string. I can count blind hexes and hindrances for myself.
 

bprobst

Elder Member
Joined
Oct 31, 2003
Messages
2,341
Reaction score
1,114
Location
Melbourne, Australia
First name
Bruce
Country
llAustralia
I mean the "eek I found a bug" message. My opponent checks LOS, I get the error message. It's a crap-shoot whether we see each other's LOS string or not (whether the error message appears or not).

I thought that disabling the LOS engine would disable the string, but apparently that's not the case, so, off it goes.
 
Top