Overlay extension -- H3 (hillock) issue

bprobst

Elder Member
Joined
Oct 31, 2003
Messages
2,275
Reaction score
1,004
Location
Melbourne, Australia
First name
Bruce
Country
llAustralia
There is a problem with the H3 overlay. It's a bit hard to describe, but basically the locating numbers of the overlay (i.e., the 1-2) swap positions depending on how the overlay is rotated. I.E. default orientation is "1-2", rotate cw still "1-2", rotate again it becomes "2-1". Which is more than a little confusing until you realise what's going on.
 

jrv

Forum Guru
Joined
May 25, 2005
Messages
21,998
Reaction score
6,145
Location
Teutoburger Wald
Country
llIceland
Drag overlay H3 onto the map. The two numeric position indicators "1" and "2" are arranged clockwise on the edge of the overlay. Press ctrl-z to rotate it once. The numeric position indicators are still arranged clockwise. Press ctrl-z a second time. The numeric position indicators are now arranged counter-clockwise on the edge. They remain arranged counter-clockwise until the overlay is rotated with ctrl-z back to the original position, when they become clockwise again.

JR
 

jrv

Forum Guru
Joined
May 25, 2005
Messages
21,998
Reaction score
6,145
Location
Teutoburger Wald
Country
llIceland
I added a bug: https://github.com/vasl-developers/vasl/issues/539

This also happens on Hi10 and Hi7. I am guessing this is due to the code that tries to keep the "1" and "2" text rotated in the "right" direction. The code tries to invert the "1" and the "2" at some point in the rotation sequence. If the numeric position indicators are located on the right side of the overlay in the overlay's original position, the code also swaps the direction (clockwise, counter-clockwise) of the indicators.

It would be nice if the numeric position indicator text rotated correctly and did not limit itself only to top-to-bottom and bottom-to-top.

JR
 
Top