New Comp - Saved Game Issues

The Purist

Elder Member
Joined
Aug 16, 2004
Messages
2,916
Reaction score
1,471
Location
In my castle by the sea, Trochu, AB
First name
Gerry
Country
llCanada
G'day gents

New comp after a crash and I have loaded the game. However, when I load a saved game file for a PbEM game the board does not show up, juts the counters on a white background. There is an overlay involved so I am not sure if that is the issue.

Need some help as my opps are waiting on their next files.

(been away from the game for awhile due to some health issues and have forgotten some of the basics to vasl).

Cheers.
 

Jazz

Inactive
Joined
Feb 3, 2003
Messages
11,618
Reaction score
2,153
Location
The Empty Quarter
Country
llLithuania
Is it a map that you need to have in your map folder? Something not part of the standard map set like a playtest or TPP HASL map?
 

zgrose

Elder Member
Joined
Jun 13, 2004
Messages
3,993
Reaction score
732
Location
Kingwood, TX
First name
Zoltan
Country
llUnited States
G'day gents
New comp after a crash and I have loaded the game. However, when I load a saved game file for a PbEM game the board does not show up, juts the counters on a white background. There is an overlay involved so I am not sure if that is the issue.
In the VASSAL window, you can choose Help...Show Error Log after you've loaded your saved game file and there will be a big wall of text that probably has at least one error in it that should help pin down the issue. You can copy/paste that text into a message here.
 

The Purist

Elder Member
Joined
Aug 16, 2004
Messages
2,916
Reaction score
1,471
Location
In my castle by the sea, Trochu, AB
First name
Gerry
Country
llCanada
Ah! Appears to be a ton of "do not have extension loaded..." messages, which is strange. I had all the files copied to the new comp but should have only needed the main VASL/VASSAL programs.

First set of errors are:

Bad Data in Module: Source: bd49.gif Error: Image not found. Turn on the Audit Trail preference to generate more details in the errorlog.
- Bad Data in Module: Source: bd23.gif Error: Image not found. Turn on the Audit Trail preference to generate more details in the errorlog.

Another error message runs:

VASL LOS disabled - unexpected error: java.lang.NullPointerException: Cannot invoke "VASL.LOS.Map.Hex.getColumnNumber()" because "upperLeft" is null. VASSAL los active

Last set (and largest) are similar to these:

This game was saved with extension '4los' loaded. You do not have this extension loaded. Place the file into the 'C:\Users\xxxx\Desktop\VASL\vasl-6.6.2_ext' folder to load it
- This game was saved with extension '5FB' loaded. You do not have this extension loaded. Place the file into the 'C:\Users\xxxx\Desktop\VASL\vasl-6.6.2_ext' folder to load it

However, when I check the extension folder they appear to be there.

Screen shot:

20735


Here a shot from the board folder. They appear to be loaded (as are the Overlays).

20736
 
Last edited:

DougRim

Elder Member
Joined
Apr 23, 2012
Messages
1,179
Reaction score
1,356
Location
Ottawa
Country
llCanada
The messages about VASL los being disabled and extensions not loaded are warning/info messages and can be ignored for now.

The only error message is the one about the Bad Data in module. There was a specific change in VASSAL (around 3.6.3 or 3.6.4 that was causing this. We issued a VASL patch in VASL 6.6.3.1.

I suggest that you either download and install VASL6.6.3.1 (recommended) OR revert VASSAL to 3.5.8. Do one or the other not both.
 

The Purist

Elder Member
Joined
Aug 16, 2004
Messages
2,916
Reaction score
1,471
Location
In my castle by the sea, Trochu, AB
First name
Gerry
Country
llCanada
3.5.8 will be the choice. Will advise.

As always,.... thanks for the assist.

Edit: Game seems to be working fine with 3.5.8. Thanks again.
 
Last edited:
Top