macOS Catalina VASL

ASLAddict

Member
Joined
Oct 16, 2018
Messages
27
Reaction score
45
Location
Saxony/Germany
Country
llGermany
Yesterday the new Mac OS Catalina was released. With it Apple throws out all 32 bit applications. VASL is shown as incompatible. Has anyone experienced if VASL works with OS Catalina?

Thanks
 

zgrose

Elder Member
Joined
Jun 13, 2004
Messages
3,569
Reaction score
529
Location
Kingwood, TX
First name
Zoltan
Country
llUnited States
I'll be upgrading today (or tonight) and will report back my findings and the appropriate workarounds. Java is already 64bit so I presume any issue would be with the launcher which I think is just a script.
 

ASLAddict

Member
Joined
Oct 16, 2018
Messages
27
Reaction score
45
Location
Saxony/Germany
Country
llGermany
I'll be upgrading today (or tonight) and will report back my findings and the appropriate workarounds. Java is already 64bit so I presume any issue would be with the launcher which I think is just a script.
Thank you for your answer and your effort.
 

ASLAddict

Member
Joined
Oct 16, 2018
Messages
27
Reaction score
45
Location
Saxony/Germany
Country
llGermany
Fresh install of Catalina. Downloaded Java8 from Oracle. Downloaded VASSAL. Downloaded VASL. Seemed to run ok.

View attachment 10479
Thank you very much for the information. Then i will probably update as well. But it won't be a complete reinstallation but just an update. I think the existing VASL installation will continue to work.
 

dlazov

Elder Member
Joined
Mar 22, 2004
Messages
7,545
Reaction score
870
Location
Toledo, Ohio
First name
Don
Country
llUnited States
As I posted in another thread, you can use Java 13 (I used brew cask install java to get it) and then you just need the special cut that zgrose posted and whala it VASSAL/VASL works great in Catalina with Java 13.
 
Top